Sign in to follow this  
Followers 0
Pube

NH2 Does Absolutely Nothing

8 posts in this topic

UPDATE: FIXED!! I've been able to fix the problem. Turns out that Half-Life 2: Episode 2 is NOT the only program I needed to run Nightmare House 2. I also needed to download and install the latest SDK (Source Dev Kit - it's free!) via steam. I accidentally stumbled on this fix after reading up on, downloading, and installing the new Black Mesa Source mod (a complete remake of Half-Life 1). Black Mesa Source only requires the latest SDK (and you don't even need a Half-Life title) to be installed. After the SDK was installed, everything was working like a charm!

Ok, I'd like to start off with the facts:

- My computer is COMPLETELY capable (hardware wise) to run any game on the market right now, and on extreme settings.

- I'm running Windows 7 Ultimate 64-bit

- I have a steam client (I've had one for a few years now)

- I own a legal (and registered with steam) copy of Half-Life 2 Episode 2

- HL2:Ep2 HAS been run before installing or even trying to starting NH2

- NH2 installer automatically chose the installation directory

Directory: "C:\Program Files (x86)\Steam\steamapps\sourcemods\"

- The NH2 desktop icon is a blank white icon, which has me question the installation path.

I've downloaded the EXE. installer twice now, thinking maybe the file was corrupt. I even installed the mod using the self-instal (.RAR) version, and again, no luck.

After every instal, I try to start NH2 through the destop icon it creates, and through steam and absolutely nothing happens. It's as if I wasn't even giving my computer

a command at all. To give you an example of what my computer does when I double click the NH2 icon, or click "Play" through steam, go ahead and go to your desktop and double click

on some random blank space........that's exactly what happens. NOTHING!

I would imagine that if the shortcut can't even find it's own image file, then I'm guessing it's the same scenario with the game itself. It must not be in the right directory for

steam to find, or even the shortcut....for some reaosn. I'd have tried to re-link the shortcut myself, but I can't find ANY NH2.exe file anywhere - which then lead me to believe

that maybe you start NH2 through HL2:Ep2 via some sort of "Mods" menu in the game itself, but no such menu exists.

How do I get this game to work?!

Share this post


Link to post
Share on other sites

Thank you so much for this- I'm replying because this was exactly my problem. It was 2 days of installing/reinstalling/researching between my mac and my laptop (yes- I have a Steam account and a legit purchase of HL2: EP2) to try to get this game working. Most of the searches I did across boards and YouTube seemed to report similar frustrations (meaning I found a lot more people reporting problems with the game than offering solutions- and the solutions were often quite technical in response and not really helpful to a primarily console player with limited technical knowledge

As a small update to the very helpful solution you found that exactly fixed my problem (and hopefully fixes others), I installed the latest SDK and still had the same exact problems (though I noticed the text color had at least changed from Red to Blue on the steam game screen for NH2, though the 'Play' button still did absolutely nothing). I then changed the dropdown from the preset Source Engine MP/ Game: Team Fortress 2 to Source Engine 2009 and it immediately fixed the problem and the game now runs great.

I really support indie games and have nothing but respect for the inherent products, but it really seems that this game has a great deal of difficulties...just some feedback that it was only my stubborn tenacity and having the week off of vacation that brought me here. It should not take 2 days and this much work to get a game to work after following the download instructions from the home page.

Share this post


Link to post
Share on other sites

UPDATE: FIXED!! I've been able to fix the problem. Turns out that Half-Life 2: Episode 2 is NOT the only program I needed to run Nightmare House 2. I also needed to download and install the latest SDK (Source Dev Kit - it's free!) via steam. I accidentally stumbled on this fix after reading up on, downloading, and installing the new Black Mesa Source mod (a complete remake of Half-Life 1). Black Mesa Source only requires the latest SDK (and you don't even need a Half-Life title) to be installed. After the SDK was installed, everything was working like a charm!

Ok, I'd like to start off with the facts:

- My computer is COMPLETELY capable (hardware wise) to run any game on the market right now, and on extreme settings.

- I'm running Windows 7 Ultimate 64-bit

- I have a steam client (I've had one for a few years now)

- I own a legal (and registered with steam) copy of Half-Life 2 Episode 2

- HL2:Ep2 HAS been run before installing or even trying to starting NH2

- NH2 installer automatically chose the installation directory

Directory: "C:\Program Files (x86)\Steam\steamapps\sourcemods\"

- The NH2 desktop icon is a blank white icon, which has me question the installation path.

I've downloaded the EXE. installer twice now, thinking maybe the file was corrupt. I even installed the mod using the self-instal (.RAR) version, and again, no luck.

After every instal, I try to start NH2 through the destop icon it creates, and through steam and absolutely nothing happens. It's as if I wasn't even giving my computer

a command at all. To give you an example of what my computer does when I double click the NH2 icon, or click "Play" through steam, go ahead and go to your desktop and double click

on some random blank space........that's exactly what happens. NOTHING!

I would imagine that if the shortcut can't even find it's own image file, then I'm guessing it's the same scenario with the game itself. It must not be in the right directory for

steam to find, or even the shortcut....for some reaosn. I'd have tried to re-link the shortcut myself, but I can't find ANY NH2.exe file anywhere - which then lead me to believe

that maybe you start NH2 through HL2:Ep2 via some sort of "Mods" menu in the game itself, but no such menu exists.

How do I get this game to work?!

Hi, I have the same problem.

- I have hl2, to him, episodes 1 and 2

- Mod installed. Exe and even the second option paste the folder with the compactness

I installed the SDK, mod still does not want to start ... What is the problem?

Please help

beztytuuxn.jpg

Share this post


Link to post
Share on other sites

UPDATE: FIXED!! I've been able to fix the problem. Turns out that Half-Life 2: Episode 2 is NOT the only program I needed to run Nightmare House 2. I also needed to download and install the latest SDK (Source Dev Kit - it's free!) via steam. I accidentally stumbled on this fix after reading up on, downloading, and installing the new Black Mesa Source mod (a complete remake of Half-Life 1). Black Mesa Source only requires the latest SDK (and you don't even need a Half-Life title) to be installed. After the SDK was installed, everything was working like a charm!

Ok, I'd like to start off with the facts:

- My computer is COMPLETELY capable (hardware wise) to run any game on the market right now, and on extreme settings.

- I'm running Windows 7 Ultimate 64-bit

- I have a steam client (I've had one for a few years now)

- I own a legal (and registered with steam) copy of Half-Life 2 Episode 2

- HL2:Ep2 HAS been run before installing or even trying to starting NH2

- NH2 installer automatically chose the installation directory

Directory: "C:\Program Files (x86)\Steam\steamapps\sourcemods\"

- The NH2 desktop icon is a blank white icon, which has me question the installation path.

I've downloaded the EXE. installer twice now, thinking maybe the file was corrupt. I even installed the mod using the self-instal (.RAR) version, and again, no luck.

After every instal, I try to start NH2 through the destop icon it creates, and through steam and absolutely nothing happens. It's as if I wasn't even giving my computer

a command at all. To give you an example of what my computer does when I double click the NH2 icon, or click "Play" through steam, go ahead and go to your desktop and double click

on some random blank space........that's exactly what happens. NOTHING!

I would imagine that if the shortcut can't even find it's own image file, then I'm guessing it's the same scenario with the game itself. It must not be in the right directory for

steam to find, or even the shortcut....for some reaosn. I'd have tried to re-link the shortcut myself, but I can't find ANY NH2.exe file anywhere - which then lead me to believe

that maybe you start NH2 through HL2:Ep2 via some sort of "Mods" menu in the game itself, but no such menu exists.

How do I get this game to work?!

Hi, I have the same problem.

- I have hl2, to him, episodes 1 and 2

- Mod installed. Exe and even the second option paste the folder with the compactness

I installed the SDK, mod still does not want to start ... What is the problem?

Please help

beztytuuxn.jpg

Make sure you've also played Episode Two at least once, so it can load all of its caches. 

I guess something's wrong with my EP2, because no matter how many times I play it, it won't load the caches.

Share this post


Link to post
Share on other sites

UPDATE: FIXED!! I've been able to fix the problem. Turns out that Half-Life 2: Episode 2 is NOT the only program I needed to run Nightmare House 2. I also needed to download and install the latest SDK (Source Dev Kit - it's free!) via steam. I accidentally stumbled on this fix after reading up on, downloading, and installing the new Black Mesa Source mod (a complete remake of Half-Life 1). Black Mesa Source only requires the latest SDK (and you don't even need a Half-Life title) to be installed. After the SDK was installed, everything was working like a charm!

Ok, I'd like to start off with the facts:

- My computer is COMPLETELY capable (hardware wise) to run any game on the market right now, and on extreme settings.

- I'm running Windows 7 Ultimate 64-bit

- I have a steam client (I've had one for a few years now)

- I own a legal (and registered with steam) copy of Half-Life 2 Episode 2

- HL2:Ep2 HAS been run before installing or even trying to starting NH2

- NH2 installer automatically chose the installation directory

Directory: "C:\Program Files (x86)\Steam\steamapps\sourcemods\"

- The NH2 desktop icon is a blank white icon, which has me question the installation path.

I've downloaded the EXE. installer twice now, thinking maybe the file was corrupt. I even installed the mod using the self-instal (.RAR) version, and again, no luck.

After every instal, I try to start NH2 through the destop icon it creates, and through steam and absolutely nothing happens. It's as if I wasn't even giving my computer

a command at all. To give you an example of what my computer does when I double click the NH2 icon, or click "Play" through steam, go ahead and go to your desktop and double click

on some random blank space........that's exactly what happens. NOTHING!

I would imagine that if the shortcut can't even find it's own image file, then I'm guessing it's the same scenario with the game itself. It must not be in the right directory for

steam to find, or even the shortcut....for some reaosn. I'd have tried to re-link the shortcut myself, but I can't find ANY NH2.exe file anywhere - which then lead me to believe

that maybe you start NH2 through HL2:Ep2 via some sort of "Mods" menu in the game itself, but no such menu exists.

How do I get this game to work?!

Hi, I have the same problem.

- I have hl2, to him, episodes 1 and 2

- Mod installed. Exe and even the second option paste the folder with the compactness

I installed the SDK, mod still does not want to start ... What is the problem?

Please help

beztytuuxn.jpg

Make sure you've also played Episode Two at least once, so it can load all of its caches. 

I guess something's wrong with my EP2, because no matter how many times I play it, it won't load the caches.

Download Source sdk 2007, in the tools section.

It works for me.

Share this post


Link to post
Share on other sites

I tried this and I cant get the game to run properly. I keep getting errors where trees and objects should be. I TRIED EVERYTHING in the stupid useless guide they posted and even this and nothing. Why would these people release a broken game and not fix it knowing there are so many people with this problem? No they ignore it and say the hell with it. They don't give a damn. Just release a bunch of guides to force people to go through hell to get a freaking mod game to work. pos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0