Sign in to follow this  
Followers 0
HELZOPRO

NH2 not even launching

7 posts in this topic

As the title says, I just bought HL2, Ep1 and Ep2 just so I could play some of the awesome mods out there, but I seem to be having a problem with Nightmare House 2, I downloaded it from We Create Stuff's website, ran the installer and everything was installed, It shows up on Steam, and is in the correct directory I believe, it's under steamapps/sourcemods then NH2.

Any help would be much appreciated, Steam has been restarted and a clean install of everything. I'm so confused as some of my friends have it running just fine.

Thanks

Share this post


Link to post
Share on other sites

Not sure if you are still looking for a solution, but another poster indicated a similiar problem I was having. The downloaded icon shows a blank white page and though the game shows in my steam list, hitting 'Play' doesn't do anything. If that is the same issue you are having- he found a method to fix it:

You need to download (free through Steam) An SDK (Source Dev Kit?) I downloaded the latest one, ran it, then changed the dropdown to Source Engine 2009 which automatically updates the game to Half-Life 2 (Source Engine MP/Team Fortress 2 seems to be the preset configuration)

Share this post


Link to post
Share on other sites

I'm getting this same issue. I just heard about the mod and was excited to try it out. Everything seemed to install just fine (I used the torrent link on the NH2 website) and it shows up in the mod folder in the program files and the games list in Steam. Clicking the play button in Steam does absolutely nothing and sending a shortcut to the desktop just gives the blank icon like you mentioned. I bought, installed, and ran Half-Life 2: Episode 2 before installing it of course.

I downloaded the Source SDK from the Steam tools list and changed the drop down menu to "Source Engine 2009" and hit close but the play button for Nightmare House 2 still does nothing. I also went back into the Source SDK and changed the "Current Game" drop down menu from Half-Life 2 to Half-Life 2: Episode Two and still got nothing.

I really want to sort this out because the mod looks amazingly fun and it's a bummer that it won't even attempt to start.

Share this post


Link to post
Share on other sites

AHA! Nevermind, problem solved. Turns out that downloading the Soruce SDK wasn't the only thing I needed. I downloaded the Source Base 2006 and 2007 as well and it finally worked!

Share this post


Link to post
Share on other sites
AHA! Nevermind, problem solved. Turns out that downloading the Soruce SDK wasn't the only thing I needed. I downloaded the Source Base 2006 and 2007 as well and it finally worked!

where to download?

Share this post


Link to post
Share on other sites
AHA! Nevermind, problem solved. Turns out that downloading the Soruce SDK wasn't the only thing I needed. I downloaded the Source Base 2006 and 2007 as well and it finally worked!

where to download?

It should be in the tools right under the source SDK.

Share this post


Link to post
Share on other sites

You need to download (free through Steam) An SDK (Source Dev Kit?) I downloaded the latest one, ran it, then changed the dropdown to Source Engine 2009 which automatically updates the game to Half-Life 2 (Source Engine MP/Team Fortress 2 seems to be the preset configuration) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0