Bug Reports and Technical Support

83 posts in this topic

Hello everyone, Underhell has been released and I am already getting bug reports ! Which mean you are awesome in finding bugs an details, and I will definitely release a patched version once I have gathered enough bug to justify uploading the whole thing again.

If you have seen any bug in the game, or anything not working, please do not hesitate to post down below !

If possible attach a screenshot of the error, bug, or glitch, and a short (or long) description of how it happened.

Thank you very much !


.Computer Requirements

1.7 GHz Processor
1024 MB RAM
DirectX® 9 level Graphics Card
Windows® Vista/7/XP/2000, Mouse, Keyboard, Internet Connection


Pentium 4 processor (3.0GHz, or better),
2048 MB RAM
DirectX® 9 level Graphics Card (or higher)
Windows® Vista/7/XP/2000, Mouse, Keyboard, Internet Connection



No subtitles, or bad subtitles ?


In game captions:
- change steam language to English or
- add this to Underhell launch options: +cc_lang "english"


Game doesn't show in the Steam Library?



Be sure you have 

and not



Before posting your error, be sure to try this :

Try to verify the integrity of your game cache.

Go to your Steam window and go in the Tools tab, and right click on Source Sdk Base 2007, then click on properties.


There click on the Local Files tab, and click on the Verify Integrity of Game Cache button.

This should fix most Local Files errors, which are VERY common



Make sure to update your graphic card drivers, as Underhell makes usage of some custom shader effects.




Too many verts for a dynamic vertex buffer (xxxxxxxx>xxxxx) Tell a programmer to up VERTEX_BUFFER_SIZE

This crash most often happens when ALT+TABBING the game, but it can also happen in very large areas with lot of combat happening.

It is very rare, if it happens, just load your latest save and it should not happen again within the same map.

Just reload and continue playing as normal.

"Can't load lump 8, allocation of ******** bytes failed!!!"

This is a very rare memory crash that happens after many hours of continuous play.

We intend to fix it as soon as possible in a future patch. If you get this error, simply reload your latest save from the Load Game menu, and the error should not happen again.





CFileSystem_Steam::Init() failed: failed to find steam interface

This is a SteamPipe related issue, unrealted to the mod itself. Head over to your Steam TOOLS list.

Right click your SOURCE SDK BASE 2007 and click properties then click the BETAS tab and chose the SteamPipe beta as the beta you would like to opt into.



It seems underhell will crash if you try to run it on low settings, so I upped the settings and it work. Might not affect everyone.




Turning the flashlight on seems to crash the game?


This appears to be a drivers issue on some graphic cards. See the Black Mesa FAQ for more info.

Try reducing shadows details to Medium or Low, or try disabling HDR (set it to none)


If above fails try the following fix :

(Warning: This fix will disable the flashlight shadows, and cause flashlights to go through walls)






The game keeps randomly crashing after I wake up in the bed, and walk downstairs.

According to Windows, it has something to do with a file called "shadereditor_2007.dll". Of course, I have no clue if that is the main cause, though...





EDIT : I just figured out that the problem was due to the game being in DirectX 8. Switching it to DirectX 9 fixed the problem.






Here's what I found: ABSOLUTELY, UNDER NO CIRCUMSTANCES, NEVER EVER USE MSI AFTERBURNER WITH THIS GAME. ITS DLL BLOCKING TECHNOLOGY WILL SLOW DOWN YOUR GAME DRAMATICALLY AND DISABLING THIS FEATURE HAS NO EFFECT. Will repost this info on my blog (it's pretty much my username with a .com) and I look forward to giving my viewers a good review of this game!!



Engine Error: Could not load library client

This is most likely related to a corrupt download/extraction of the file, try re-installing or redownloading.

If it still happens, try logging out of your Steam completely, and log back in. :  Thanks to "Ardent_Assailant" for the fix



Game Stuttering/Microfreezes :


Figured out how to stop stuttering, may as well post my cure for the people who experience the same problem.


The problem was that multicore rendering was blacked out in the options menu, every core was being used. Source doesnt really like multicore.

So I went to task manager, right clicked hl2.exe, "Set Affinity" and set it to just Core 1. Runs like a dream now.







Share this post

Link to post
Share on other sites

Caused by my save file or game bug, I don't know.
I found doors. I got "Instruction at referenced memory could not be read", while pressing E (opening door). Always. Red Doors of Death?
Nearest save file: chapter1_06  (before we flip three levers)
I attached demo file. So you will know which door.
"could not be read" happened only with this door, I didn't find other objects causing this crash.
(now, I'm in chapter1_08.)
I checked SDK Cache, I didn't ATL+TAB.
EDIT. Useful stuff.



We can not ALT+TAB the game because of "Too many verts for a dynamic vertex buffer" error.
There is other way, fake full-screen mode.

Borderless window. Just add those to Underhell launch options:
-window -noborder -w 1024 -h 768 -x 0 -y 0
Of course, instead 1024 and 768 you can choose other values.
We can alt tab or minimize game window ( Windows+M or Windows+D or Alt+Space+M )
Cons is: we can not change brightness in game, we have to use graphic card control panel (e.g. Nvidia control panel)



"weird survivors", they should stay in safe room, but, they keep following Jake

You have a survivor and you don't know his/her name, do this:
1. while in safe room
2. do save
3. look at your survivor, type "ent_remove" in the console, you will get response, for example:
Removed npc_citizen(Survivor_Joseph)
4. now you know that your survivor name is Joseph
5. load save and type
sv_cheats 1
ent_fire Relay_Joseph_Rescued enable
sv_cheats 0


You can not kick and run (when not injured)

sv_cheats 1
ent_fire SpeedMod_Hermit modifyspeed 1
ent_fire !player enablekick 1
sv_cheats 0


Share this post

Link to post
Share on other sites

Can't seem to figure out how to use the spoiler thing so don't read below if you don't want to know.


So after assembling the Cypher and making my way back to the safe room with the memory card, I face the front doors with Terry moving the bookcase away from the door, but with no animation, staring at me, and then walking back to his chair. The door won't open, and I'm unable to get back in the safe room, no matter how many times I've restarted or loaded previous saves, this happens. Anything that can be done?

Share this post

Link to post
Share on other sites

Ok I have a problem and its that when I load up the house I start at the bed I get out of the bed and I cant move I can jump and duck but I cant move I can look around using the mouse and its also at the part where it say to go to bed early I can even enter the bed and go to the dream world but I cant still move there.

Share this post

Link to post
Share on other sites

Try going back to sleep, and then pressing use only ONCE on the wake up door.


Archer : I found the cause for your bug, it's because you pressed use on the bed while you were reading the diary page.


Go in the console while in the house and enter the following.


sv_cheats 1

ent_fire ui_diary activate

ent_fire ui_diary deactivate


I will make sure this cannot happen, in the next patch.

Share this post

Link to post
Share on other sites

Has anybody noticed this yet? If not then im suprised!

If you reload while in ironsights the clip will instantly get fully reloaded even if the reload animation hasnt finished


Oh also i forgot!

The sniper will reload instantly regardless whether you are aiming or not


EDIT: And another one!

When you exit out of ironsights straight after youve shot a bullet you will shoot twice

So if you use a shotgun it will pump immediadly aswell as the sniper

And with the python you shoot twice... This pissed me off because i ran out of ammo very darn quick


EDIT2: Oh my! Another one!

During the prologue in the dual elites part once the cutscene starts where you walk out the scanner you are actually able to KICK yourself so the NPC dies!


EDIT3: Phoo! Another one!!

If you have nightvision equiped when you get gassed after seeing the billion hostages the nightvision will stay equiped until you are back in the house


EDIT4: Seems like were having a massive bug hunt!

During the dream hall in the prologue the player can still interact with the first door during its opening sequence

allowing the sound to be repeated aswell as repeating the fade

Share this post

Link to post
Share on other sites

This particular card is invisible when "model quality" isn't at max preset. Trash becomes flat and conceals it. Texture quality can be anything.

Developers, in the next patch, can move it like this:


Share this post

Link to post
Share on other sites

Inside registry.


(yours can be different)


When shadows are set to Low:

r_shadowrendertotexture = 0

ShadowDepthTexture = 0


When shadows are set to medium:

r_shadowrendertotexture = 1

ShadowDepthTexture = 0


When shadows are set to high:

r_shadowrendertotexture = 1

ShadowDepthTexture = 1


Try this: run Underhell, set everything to max (what you can), shutdown Underhell, go to registry, edit values, launch Underhell. Also, can set r_shadowrendertotexture with "launch options" (+r_shadowrendertotexture 1).

It might work, or not.

Share this post

Link to post
Share on other sites

So I got stuck in the floor of this elevator. Luckily there is a checkpoint before this happens. What I did to get stuck was crouch behind the crates, ride the elevator down, loading screen happens, then I'm stuck in the floor. I just reloaded the checkpoint, and waited until after the loading screen to crouch.


Share this post

Link to post
Share on other sites

Oh no no no! A bug!

When you start a chapter all the bateries you collected in the house will remain meaning if you had 16 batteries from the house you will start with 16 batteries in chapter 1

Share this post

Link to post
Share on other sites

I have an issue with the inventory screen when playing on 2560x1600 resolution. The right and bottom sides of it get cut off and can't be accessed.


Screenshot of the issue:


I've verified the integrity of the Source Sdk Base 2007 game cache, changed to lower resolutions and back a few times (it lines up fine at lower resolutions), and restarted the game a few times, but it just doesn't seem to want to line up correctly at 2560x1600.


Is there any way to fix this? Any file I could edit somewhere?

Share this post

Link to post
Share on other sites

That's very sad, but unfortunately we haven't tested the UI in such resolutions, none of our monitors have those resolutions available.


One of the downsides of being an indie I suppose!

Share this post

Link to post
Share on other sites

That's very sad, but unfortunately we haven't tested the UI in such resolutions, none of our monitors have those resolutions available.


One of the downsides of being an indie I suppose!


Decided to tinker myself and found a solution. In the \Underhell\resource\ui folder there is a inventorypanel.res file, with variables 'wide' and 'tall' set to 1024 and 512 respectfully. Increasing those each by 25%, to 1280 and 640, lets me see and interact with all of my inventory.


Screenshot of the inventory after editing the file:


I don't know if this is the "correct" way to fix the issue, and the inventory box is a little off center, but doing that lets it function normally with both tooltips and right clicking on items.


Since I have a 2560x1600 monitor handy, if there's anything you ever want me to help test out just ask, I'd be happy to oblige.

Share this post

Link to post
Share on other sites

So seeing as this is the bug reports and thread for things that aren't working, I appear to be having a VERY serious bug problem with my copy of Underhell.


I downloaded it from Desura, it has experienced a few crashes, but I don't really mind that. I can STILL PLAY the game with crashes.


This bug, makes it impossible.


You see, I'm on the part of the game when Jake has to reactivate the Multiple Generator thingy, and he has to flip 3 switches to reactivate it and finish the level. 




When I tried to do this, the final lever (the middle one) would not respond to me E command. So, I restarted the level and tried again, running into the same error.


Please help

Share this post

Link to post
Share on other sites

If the gas is removed from the Northern Wing Labs (Endgame) before Jake reads the PDA telling him to start fires, the side objective will reactivate and not be completable.

Share this post

Link to post
Share on other sites

Hi everyone,


so far I really enjoyed this game. Love it. But now it crashes.

The crash: When I leave the shooting range to collect the pieces for the cypher and move towards the workshop, the game crashes. Every time at the same spot. Or when I take a different route, it happens when I get close to the workshop. It tried loading old saves, restarting steam and so on, but nothing changed. I did check the source2007sdk cache and it's fine.

If I load an older save it crashes after some short time.

Here is a screenshot of the crash:

I googled the error module "Stack Hash" and found this to solve it:




  1. Click on the Start menu and then go to the Control Panel.

  2. Click on System Maintenance and then System.

  3. Choose Advanced System Settings.

  4. Under System Properties, select Settings from the Performance section at the top.

  5. Click on the Data Execution Prevention tab.

  6. Select “Turn on DEP for all programs and services except those I select”.

  7. Find the executable file for the application that triggered the error.

  8. Select the application causing the error and click Open to add it to your DEP Exceptions list.

  9. Click OK to save your new settings.


After I did this, the error message looked like this:

But at the next crash it looked like the first error message again.

I don't have problems with other games (HL2 episode 1 for example).

Can someone help me? I would love to continue playing!

Share this post

Link to post
Share on other sites

Unfortunately I cannot read german.


Try loading an earlier save and replaying from there, let me know if that helps.

Share this post

Link to post
Share on other sites

Unfortunately I cannot read german.


Try loading an earlier save and replaying from there, let me know if that helps.

Well I tried to provide as much information as possible and I guess the error codes and whatnot are the same no matter the language.

Like I said in my first post, if I load an earlier save it crashes too (pretty fast). But since at my last save it will always crash at the same point (when I get close to the workshop area) I would guess it's loading something which causes the error.

Just stranged that I was playing for hours and everything went smooth. Can't actually remember that I changed something.

EDIT: I might reinstall windows in a few days anyway so I will download the mod again and see if that changes anything...

Share this post

Link to post
Share on other sites


Open your Underhell_Chapter1_1.2.7z with WinRAR or 7zip. Click "Test" icon. Just to be sure.

(to be perfectly sure, you can extract it again and overwrite files inside sourcemods\Underhell,  backup "save" folder first)


Or... I have an idea. Can you upload your latest save file (go to \Steam\steamapps\sourcemods\Underhell\SAVE and sort files by modification date, select latest SAV file (autosave) or SAV TGA pair, compress them with WinRAR or 7zip, upload somewhere and give link.)


If it's damaged data (not game files, not save file, but data/structures stored in that save file), I think:

- that damaged data occurred long time ago (and it's inside your latest autosaves, last two, last five, who knows)[/size]

- I should have the same error at the same place (after loading your save file)


- If I don't get that error maybe it will fix it, and I can send it back to you. (if I remember correctly, there will be autosave after collecting first piece, I will send you back that autosave)







About your screenshot, in many cases, informations inside that window are useless.

drwtsn32 (post mortem debugger) from WinXP is slightly better.

Share this post

Link to post
Share on other sites

I had just recently re-installed Underhell to check if it has proper source recorder support (if it does, I'm going to make a fan-made trailer in my spare time!)

However, after installing the mod and rebooting steam, clicking 'play' on Underhell does completely nothing. Steam recognizes the mod as it got sorted into the category and Steam showed me the last play date (September).

I verified cache of all the Source SDK Base tools.

I can see previous posts mentioning this, but saying thanks to a post inexistent in this forum gives me no leads for a solution whatsoever.

Anyway, I just found a solution.

In case anyone is going to do the same mistake I did, try to opt out of the Steam Beta and restart Steam. The mod should launch just fine then.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now